Pale Moon 29.2.0 nu mai acceptă extensiile vechi Firefox care nu sunt portate

Când Mozilla a trecut de la sistemul său vechi de completare la WebExtensions, furcile Firefox, cum ar fi Pale Moon, au văzut o creștere a utilizatorilor care doreau să continue să utilizeze extensii pe care noul sistem Mozilla nu le mai suporta. Nu toate extensiile au funcționat, dar multe au funcționat, iar utilizatorii ar putea continua să utilizeze aceste extensii.

Lansarea Pale Moon 29.2.0 modifică compatibilitatea extensiilor browserului într-un mod major, deoarece elimină suportul pentru extensiile vechi Firefox care nu sunt ajustate pentru a funcționa cu browserul Pale Moon. În prezent sunt disponibile aproximativ 230 de extensii pentru Pale Moon pe site-ul oficial al suplimentelor Pale Moon , inclusiv extensii populare precum Decentraleyes, uBlock Origin (Legacy) sau FoxyProxy.

In conformitate la o postare pe forum a Moonchild, proprietarul proiectului Pale Moon, suportul pentru extensiile Firefox a fost întotdeauna considerat temporar de către echipa de dezvoltare. Este posibil ca extensiile Firefox clasice să nu se instaleze deloc în Pale Moon sau să introducă probleme de compatibilitate, iar acesta este unul dintre principalele motive pentru blocarea extensiilor Firefox clasice în Pale Moon 29.2.0.

compatibilitate addon cu luna pală 29.2.0

Extensiile care nu sunt compatibile pot fi portate pentru a le face compatibile cu browserul Pale Moon, dar cine o va face? Pentru echipa proiectului Pale Moon, răspunsul este clar. Comunitatea trebuie să se intensifice pentru a se asigura că extensiile pe care le folosesc rămân compatibile cu browserul. În mod real, majoritatea utilizatorilor de browser nu știu cum să creeze extensii de browser sau să le modifice pentru a le face să funcționeze. Nici echipa Pale Moon nu poate transfera majoritatea extensiilor de browser către browser, ceea ce lasă un grup mic de membri ai comunității cu abilitățile și timpul necesar pentru a transporta unele dintre extensii în browser.

Un subiect este disponibil pe forumul oficial Pale Moon pentru postează extensii critice numai pentru Firefox .

Utilizatorii Pale Moon pot rămâne în versiunea 29.1.1 a browserului ca măsură temporară pentru a continua să folosească extensii care altfel ar fi dezactivate în Pale Moon 29.2.0 sau o versiune ulterioară. O opțiune bună pentru a testa compatibilitatea este să folosiți o copie portabilă a Pale Moon 29.2.0 și să testați compatibilitatea extensiilor în acea versiune pentru a vedea care dintre extensiile instalate rămân compatibile și care nu. Nu este recomandată trecerea la o versiune anterioară a Pale Moon după instalarea actualizării 29.2.0, deoarece poate introduce probleme de compatibilitate a profilului.

Pale Moon 29.2.0 a fost lansat pe 27 aprilie 2021 .

Acum tu : folosești Pale Moon? Sunteți afectat de schimbarea compatibilității?